Start a new topic

Family Zone no longer working on MacBook

My charming 13 year old has done something to his MacBook and the ability for me to log in or have it connected to my device is no longer there. I get messages saying the device is not connected and when I do the search on his MacBook it is saying it’s not detected. I have tried to delete the app off his computer and empty the trash and then start again with the reinstall however it now comes up with a message saying- Problem running post- install step. Installation may no be complete correctly Error running/ application/ family zone/ mobilezoneagent/ bin/fc-system-service_darwin-amd64–service start: child process exited abnormally. It then has a pet for me to click ok. The message then comes up with the completing mobile zone wizard set up so I hit finish but then nothing appears on his menu bar. Please help 

1 person has this question

Hi Natasha,

I have outlined instructions below that will fix the issue you are having with your son's MacBook.

  1. Uninstall Mobile Zone using Applications/FamilyZone/MobileZone/uninstall
  2. Click onto Desktop > Select go at the top bar > Computer > Macintosh HD > Library > LaunchDaemons > Delete any and all fc-agent entries
    Also, Macintosh HD > Library > Preferences > delete the com.familyzone.MobileZone.plist entry
  3. Delete install file and zip file from Downloads folder
  4. Delete from trash
  5. Restart device
  6. Reinstall Mobile Zone

If you are having any issues with these steps, please don't hesitate to contact us and our support staff would be happy to help.


Zac J

Customer Service Representative

I've encountered the same problem this morning. After reading Natasha's post, now I'm not certain whether my son tried to remove it or something happened by itself. I tried to reinstall following instructions provided by online chat but failed. I will try it again once my son return from his school this afternoon. Btw did you have any luck of reinstalling the app again on your daughter's MacBook?


This was the error message received

Hi Fazidin,

I have sent you a email

Hi Damian M and Natasha,

I was able to reinstall the app on the MacBook. This time I used chrome to download the app. Not sure what's the difference between chrome and safari. Seems to work when downloaded with chrome.
Login to post a comment