Start a new topic

VPN disconnected when Android device restarted

Hi Team,


I have discovered that when my daughters Android 7.0 device is restarted, the VPN does not automatically reconnect. As a result none of the FZ rules are in effect. Can you please suggest how we can force the VPN to start after an Android reboot?


Hi Nathan!

Could you please confirm what type of device this is? Is it a Samsung, Oppo, Huawei, etc?

If this is an Oppo, they have extra security settings that may interfere with our VPN. Nevertheless, we will try to resolve this one for you once you're able to provide more information.

Roze

I believe that I also have a similar issue with an Alcatel One Touch Pixi 3 (4.5). 

A couple of times when the phone was restarted it had a pop-up which asked for permission to use the FZ VPN.

Hi Roze


I’ve worked it out. How the tricky little buggers sussed it out I have no idea, maybe it was a fluke. I have been able to reproduce the sequence across 3 android devices now.


When flight mode is selected on the device, restart the phone. When the phone reboots, the VPN does not start because it is still in flight mode. All you need to do to enable full internet access is turn off flight mode….the VPN does not start up again.


To reverse it and reinstate the VPN, turn off flight mode, reboot the device. The VPN starts after reboot because data is enabled.


I hope this helps in trying to find a resolution to the issue.

Hi Nathan,

This is very valuable, thank you for this. I've passed this to our Quality Assurance team and will hopefully have more information for you soon.

Roze

Can you please advise if there has been any update to what may described as, a significant flaw. The kids are all over it.

Hi Nathan,

Our QA team has been testing a few Android devices, but are not able to narrow down their testing unless you provide a device type. It would be very beneficial to our testing team in helping you find a resolution if you are able to provide this. If you are able to provide all 3 that you reproduced the error on, that would be even better.

Roze

Hi Nathan

Our testing team have tried to replicate the situation and are able to provide the following:

Android 8.0 

- Registered Device and confirmed VPN was running

- Turned on Airplane mode

- Rebooted Device

The VPN successfully re-enabled 


Android 7.0

- Registered Device and confirmed VPN was running

- Turned on Airplane mode

- Rebooted Device

The VPN did not re-enable


Android 5.1.1

- Registered Device and confirmed VPN was running

- Turned on Airplane mode

- Rebooted Device

The VPN did not re-enable 


What I would recommend, is to firmware upgrade the Android devices onto the latest firmware version. Again, if you have the type of Android devices, we will be able to do more intricate testing.

Roze

Hi Roze, thanks for the response. Being entry level Android devices (alcatel a3 xl) there is no option to upgrade the firmware to version 8. All available version 7 updates have been applied, but this appears to be an issue with version 7. Can you please offer another solution otherwise I will have no choice but to cancel my FZ subscription.

Hi Nathan,

We have now escalated the issue to our developers and they are looking into it. I will provide you with any updates I receive.

Roze


Hi Roze, I have also discovered that if Data saver is turned on, and Mobile Zone not set to "unlimited access" then the VPN won't start either. A couple of holes to plug by the look of it.

Hi Nathan,

I followed up with our QA team. They followed the same steps and could not replicate the issue.

I'm still waiting for our developers to provide a resolution to your other query. Will get back to you as soon as I hear anything.


Roze


I still haven't heard anything regarding this issue and the ticket has been closed. Can you please advise.

Hi Nathan


Huge apologies that you were not informed, but that issue should have been resolved. If it is still an issue for you, can you please let us know and we will continue to work at the problem.


Regards

Hugh

Login to post a comment